How To Configure RIPv2 in Packet Tracer

In this lab, I am gonna teach you How To Configure RIPv2 in Packet Tracer

RIPv2 In Packet Tracer – VLSM

Given Network: 196.50.50.0

1) Required hosts on Router 1= 100

2) Required hosts on Router 2= 60

3) Required hosts on Router 3= 30

How To Configure RIPv2 in Packet Tracer

R1<= 100

100<= 2n – 2

100<= 27 – 2

100<= 128 – 2

100<= 126

Total number of network bits = 32

32 – n = 32 – 7 = 25 (CIDR value of given network i.e. Router 1)

i.e. 196.50.50.0/25

N.S.M = 11111111. 11111111. 11111111.10000000

                        = 255.255.255.128

Block Size        = 256 – N.S.M

                        = 256 – 128 = 128

Note: Add this block size in given network so that we can get our new network for Router 2.

So the new network is 196.50.50.0/?

Now find FVH, LVH and Broadcast address

Given Network19650500
First Valid Host-FVH19650501
Last Valid Host-LVH1965050126
Broadcast1965050127
New Network1965050128

R2<= 14

60<= 2n – 2

60<= 26 – 2

60<= 64 – 2

60<= 62

Total number of network bits = 32

32 – n = 32 – 6 = 26 (CIDR value of given network i.e. Router 2)

i.e. 196.50.50.128/26

N.S.M = 11111111. 11111111. 11111111.11000000

                        = 255.255.255.192

Block Size        = 256 – N.S.M

                        = 256 – 192 = 64

Note: Add this block size in given network so that we can get our new network for Router 3.

So the new network is 196.50.50.192/?

Now find FVH, LVH and Broadcast address

Given Network1965050128
First Valid Host-FVH1965050129
Last Valid Host-LVH1965050190
Broadcast1965050191
New Network1965050192

R3<= 30

30<= 2n – 2

30<= 25 – 2

30<= 32 – 2

30<= 30

Total number of network bits = 32

32 – n = 32 – 5 = 27 (CIDR value of given network i.e. Router 3)

i.e.196.50.50.192/27

N.S.M = 11111111. 11111111. 11111111.11100000

                        = 255.255.255.224

Block Size        = 256 – N.S.M

                        = 256 – 224 = 32

Note: Add this block size in given network so that we can get our new network for Router 1 and 2 (Virtual Network).

So the new network is 196.50.50.224/?

Now find FVH, LVH and Broadcast address

Given Network1965050192
First Valid Host-FVH1965050193
Last Valid Host-LVH1965050222
Broadcast1965050223
New Network1965050224

Router 1 & 2 <= 2 hosts (we required only two IP to connect 2 routers)

2 <= 2n – 2

2 <= 22 – 2

2 <= 4 – 2

2 <= 2

Total number of network bits = 32

32 – n = 32 – 2 = 30 (CIDR of Virtual network (R1&R2)

i.e. 196.50.50.224/30

N.S.M = 11111111.11111111.11111111.11111100

= 255.255.255.252

Block Size        = 256 – N.S.M

= 256 – 252 = 4

Note: Add this block size in given network so that we can get our new network for Router 2 and 3 (Virtual Network).

so the new network is 196.50.50.228/?

Now find FVH, LVH and Broadcast address

Given Network1965050224
First Valid Host-FVH1965050225
Last Valid Host-LVH1965050226
Broadcast1965050227
New Network1965050228

Router 2 & 3 <= 2 hosts (we required only two IP to connect 2 routers)

2 <= 2n – 2

2 <= 22 – 2

2 <= 4 – 2

2 <= 2

Total number of network bits = 32

32 – n = 32 – 2 = 30 (CIDR of Virtual network (R2&R3)

i.e. 196.50.50.228/30

N.S.M = 11111111.11111111.11111111.11111100

= 255.255.255.252

Block Size        = 256 – N.S.M

= 256 – 252 = 4

Note: Add this block size in given network so that we can get our new network for Router 4. This network can be used in future.

so the new network is 196.50.50.232/?

Now find FVH, LVH and Broadcast address

Given Network1965050228
First Valid Host-FVH1965050229
Last Valid Host-LVH1965050230
Broadcast1965050231
New Network1965050232

Basic Configuration on Router 1

Router>enable
Router#configure terminal
Router(config)#hostname R1
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 196.50.50.1 255.255.255.128
R1(config-if)#no  shutdown
R1(config-if)#exit  

R1(config)#interface serial 0/0/0
R1(config-if)#ip address 196.50.50.225 255.255.255.252
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#exit
R1#write

Basic Configuration on Router 2

Router>enable
Router#configure terminal
Router(config)#hostname R2
R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 196.50.50.129 255.255.255.192
R2(config-if)#no  shutdown
R2(config-if)#exit  

R2(config)#interface serial 0/1/0
R2(config-if)#ip address 196.50.50.226 255.255.255.252
R2(config-if)#no  shutdown
R2(config-if)#exit  
R2(config)#interface serial 0/0/0
R2(config-if)#ip address 196.50.50.229 255.255.255.252
R2(config-if)#clock rate 64000
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#exit
R2#write

Basic Configuration on Router 3

Router>enable
Router#configure terminal
Router(config)#hostname R3
R3(config)#interface fastEthernet 0/0
R3(config-if)#ip address 196.50.50.193 255.255.255.224
R3(config-if)#no  shutdown
R3(config-if)#exit  

R3(config)#interface serial 0/1/0
R3(config-if)#ip address 196.50.50.230 255.255.255.252
R3(config-if)#no  shutdown
R3(config-if)#exit
R3(config)#exit
R3#write
How To Configure RIPv2 in Packet Tracer

RIPv2 In Packet Tracer – RIP Configuration on Router 1

R1>enable  

R1#show ip route connected  
C   196.50.50.0/25  is directly connected, FastEthernet0/0  
C   196.50.50.224/30  is directly connected, Serial0/0/0  

R1#configure terminal
R1(config)#router rip
R1(config-router)#no  auto-summary
R1(config-router)#version 2
R1(config-router)#network 196.50.50.0
R1(config-router)#network 196.50.50.224
R1(config-router)#exit
R1(config)#exit
R1#write

RIPv2 In Packet Tracer – RIP Configuration on Router 2

R2>enable  

R2#show ip route connected  
C   196.50.50.128/26  is directly connected, FastEthernet0/0  
C   196.50.50.224/30  is directly connected, Serial0/1/0  
C   196.50.50.228/30  is directly connected, Serial0/0/0  

R2#configure terminal
R2(config)#router rip
R2(config-router)#no auto-summary
R2(config-router)#version 2
R2(config-router)#network 196.50.50.128
R2(config-router)#network 196.50.50.224
R2(config-router)#network 196.50.50.228
R2(config-router)#exit
R2(config)#exit
R2#write

RIPv2 In Packet Tracer – RIP Configuration on Router 3

R3>enable  

R3#show ip route connected  
C   196.50.50.192/27  is directly connected, FastEthernet0/0  
C   196.50.50.228/30  is directly connected, Serial0/1/0  

R3#configure terminal
R3(config)#router rip
R3(config-router)#no auto-summary
R3(config-router)#version 2
R3(config-router)#network 196.50.50.192
R3(config-router)#network 196.50.50.228
R3(config-router)#exit
R3(config)#exit
R3#write

Verification on Router 1

R1#show ip route     
196.50.50.0/24 is variably subnetted, 5 subnets, 4 masks
C       196.50.50.0/25 is directly connected, FastEthernet0/0
R       196.50.50.128/26 [120/1] via 196.50.50.226, 00:00:09, Serial0/0/0
R       196.50.50.192/27 [120/2] via 196.50.50.226, 00:00:09, Serial0/0/0
C       196.50.50.224/30 is directly connected, Serial0/0/0
R       196.50.50.228/30 [120/1] via 196.50.50.226, 00:00:09, Serial0/0/0

Verification on Router 2

R2#show ip route     
196.50.50.0/24 is variably subnetted, 5 subnets, 4 masks
R       196.50.50.0/25 [120/1] via 196.50.50.225, 00:00:12, Serial0/1/0
C       196.50.50.128/26 is directly connected, FastEthernet0/0
R       196.50.50.192/27 [120/1] via 196.50.50.230, 00:00:20, Serial0/0/0
C       196.50.50.224/30 is directly connected, Serial0/1/0
C       196.50.50.228/30 is directly connected, Serial0/0/0

Verification on Router 3

R3#show ip route     
196.50.50.0/24 is variably subnetted, 5 subnets, 4 masks
R       196.50.50.0/25 [120/2] via 196.50.50.229, 00:00:22, Serial0/1/0
R       196.50.50.128/26 [120/1] via 196.50.50.229, 00:00:22, Serial0/1/0
C       196.50.50.192/27 is directly connected, FastEthernet0/0
R       196.50.50.224/30 [120/1] via 196.50.50.229, 00:00:22, Serial0/1/0
C       196.50.50.228/30 is directly connected, Serial0/1/0
How To Configure RIPv2 in Packet Tracer

One thought on “How To Configure RIPv2 in Packet Tracer”

Leave a Reply

Your email address will not be published.